summaryrefslogtreecommitdiff
path: root/absl/random/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Laramie Leavitt <lar@google.com>2022-06-02 10:08:08 -0700
committerGravatar Copybara-Service <copybara-worker@google.com>2022-06-02 10:08:59 -0700
commitbed94589f27d7fdfa34ede5988203369d170cec3 (patch)
treef2ea3f182f59b1c360b82ce1969cf7a61c00033c /absl/random/CMakeLists.txt
parentc34c552a1a547a47474f32f1b89de030aa4ff949 (diff)
Rework NonsecureURBGBase seed sequence.
Decompose RandenPoolSeedSeq from NonsecureURBGBase. Adjust how the RandenPoolSeedSeq detects contiguous buffers passed to the generate function. Previously it made incorrect assumptions regarding the contiguous concept, which have been replaced with some type-based tests for a small number of known contiguous random access iterator types, including raw pointers. PiperOrigin-RevId: 452564114 Change-Id: Idab1df9dd078d8e5c565c7fa7ccb9c0d3d392ad2
Diffstat (limited to 'absl/random/CMakeLists.txt')
-rw-r--r--absl/random/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/absl/random/CMakeLists.txt b/absl/random/CMakeLists.txt
index b4ada69b..c3f0b450 100644
--- a/absl/random/CMakeLists.txt
+++ b/absl/random/CMakeLists.txt
@@ -727,7 +727,7 @@ absl_cc_library(
${ABSL_DEFAULT_LINKOPTS}
DEPS
absl::core_headers
- absl::optional
+ absl::inlined_vector
absl::random_internal_pool_urbg
absl::random_internal_salted_seed_seq
absl::random_internal_seed_material