summaryrefslogtreecommitdiff
path: root/absl/container/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Evan Brown <ezb@google.com>2023-09-12 09:14:32 -0700
committerGravatar Copybara-Service <copybara-worker@google.com>2023-09-12 09:15:26 -0700
commit5ae23ed130027e2376e0868ec4bb4fa358b7e238 (patch)
tree0e7cf0c8c3444ef0a620627a3eb9f528f202c586 /absl/container/CMakeLists.txt
parentf01b1b56de359de540c97a7898ff3011c47e2c26 (diff)
Make PolicyTraits::transfer_uses_memcpy() true for node_hash_* tables.
This should enable binary size savings for now and more efficiency improvements with small buffer optimization. PiperOrigin-RevId: 564741270 Change-Id: Icf204d88256243eb60464439a52dd589d7a559cb
Diffstat (limited to 'absl/container/CMakeLists.txt')
-rw-r--r--absl/container/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/absl/container/CMakeLists.txt b/absl/container/CMakeLists.txt
index 64f6965a..f5ef0ddb 100644
--- a/absl/container/CMakeLists.txt
+++ b/absl/container/CMakeLists.txt
@@ -577,6 +577,7 @@ absl_cc_test(
${ABSL_TEST_COPTS}
DEPS
absl::common_policy_traits
+ absl::config
GTest::gmock_main
)
@@ -660,6 +661,7 @@ absl_cc_test(
COPTS
${ABSL_TEST_COPTS}
DEPS
+ absl::config
absl::hash_policy_traits
absl::node_slot_policy
GTest::gmock_main