summaryrefslogtreecommitdiff
path: root/absl/container/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Evan Brown <ezb@google.com>2023-09-21 11:57:32 -0700
committerGravatar Copybara-Service <copybara-worker@google.com>2023-09-21 11:58:33 -0700
commit821756c32ee197556905a94910e631721113dbb3 (patch)
tree90ec4565125e57797e9e0d83f2f1835de2bd7d83 /absl/container/CMakeLists.txt
parente313f0eddd53ecebbfc057088a130a34acf6c1f8 (diff)
Replace BtreeAllocatorTest with individual test cases for copy/move/swap propagation (defined in test_allocator.h) and minimal alignment.
Also remove some extraneous value_types from typed tests. The motivation is to reduce btree_test compile time. PiperOrigin-RevId: 567376572 Change-Id: I6ac6130b99faeadaedab8c2c7b05d5e23e77cc1e
Diffstat (limited to 'absl/container/CMakeLists.txt')
-rw-r--r--absl/container/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/absl/container/CMakeLists.txt b/absl/container/CMakeLists.txt
index bfe0634b..a1633514 100644
--- a/absl/container/CMakeLists.txt
+++ b/absl/container/CMakeLists.txt
@@ -211,6 +211,7 @@ absl_cc_library(
${ABSL_DEFAULT_COPTS}
DEPS
absl::config
+ GTest::gmock
)
absl_cc_test(