summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Christoph GrĂ¼ninger <foss@grueninger.de>2024-07-09 08:59:36 -0700
committerGravatar Copybara-Service <copybara-worker@google.com>2024-07-09 09:00:35 -0700
commitf46495ea96f68fc3f6c394f099b2992743f6ff7f (patch)
tree752511d476c5fe98a973624e33dbafc504032ae3 /CMakeLists.txt
parentaf4c589ed6f312372bb02bfaacb62c14598ceb04 (diff)
PR #1706: Require CMake version 3.16
Imported from GitHub PR https://github.com/abseil/abseil-cpp/pull/1706 Follow Google OSS policy. Merge 2ba42b9e5a9ac8c9fe0609fd1ac4cad24714727a into af4c589ed6f312372bb02bfaacb62c14598ceb04 Merging this change closes #1706 COPYBARA_INTEGRATE_REVIEW=https://github.com/abseil/abseil-cpp/pull/1706 from gruenich:feature/cmake-3-16 2ba42b9e5a9ac8c9fe0609fd1ac4cad24714727a PiperOrigin-RevId: 650646746 Change-Id: Ib600608fbc727161c8b8e69cda9a09637188fef8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt39
1 files changed, 2 insertions, 37 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d88283b2..650ed70e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,43 +15,8 @@
#
# https://github.com/google/oss-policies-info/blob/main/foundational-cxx-support-matrix.md
-# As of 2022-09-06, CMake 3.10 is the minimum supported version.
-cmake_minimum_required(VERSION 3.10)
-
-# Compiler id for Apple Clang is now AppleClang.
-if (POLICY CMP0025)
- cmake_policy(SET CMP0025 NEW)
-endif (POLICY CMP0025)
-
-# if command can use IN_LIST
-if (POLICY CMP0057)
- cmake_policy(SET CMP0057 NEW)
-endif (POLICY CMP0057)
-
-# Project version variables are the empty string if version is unspecified
-if (POLICY CMP0048)
- cmake_policy(SET CMP0048 NEW)
-endif (POLICY CMP0048)
-
-# Honor the GTest_ROOT variable if specified
-if (POLICY CMP0074)
- cmake_policy(SET CMP0074 NEW)
-endif (POLICY CMP0074)
-
-# option() honor variables
-if (POLICY CMP0077)
- cmake_policy(SET CMP0077 NEW)
-endif (POLICY CMP0077)
-
-# Allow the user to specify the MSVC runtime
-if (POLICY CMP0091)
- cmake_policy(SET CMP0091 NEW)
-endif (POLICY CMP0091)
-
-# try_compile() honors the CMAKE_CXX_STANDARD value
-if (POLICY CMP0067)
- cmake_policy(SET CMP0067 NEW)
-endif (POLICY CMP0067)
+# As of 2024-07-01, CMake 3.16 is the minimum supported version.
+cmake_minimum_required(VERSION 3.16)
# Allow the user to specify the CMAKE_MSVC_DEBUG_INFORMATION_FORMAT
if (POLICY CMP0141)