summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Derek Mauro <761129+derekmauro@users.noreply.github.com>2021-03-25 09:27:44 -0400
committerGravatar GitHub <noreply@github.com>2021-03-25 09:27:44 -0400
commit997aaf3a28308eba1b9156aa35ab7bca9688e9f6 (patch)
tree719f5ebfd58b8085f10782d74225a076143d9e39 /CMakeLists.txt
parent1fdbe1ea1b8c835c11ed6fbec4d4259ad104f765 (diff)
Apply LTS transformations for 20210324 LTS branch (#920)20210324.rc120210324.0
* Apply LTS transformations for 20210324 LTS branch * Change the SOVERSION to make MacOS happy MacOS expects the first part of the SOVERSION to fit into 16 bits.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 2 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e09e335c..3a73f707 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,7 +45,7 @@ endif (POLICY CMP0077)
# This must come before the project() and include(CTest) lines.
OPTION(BUILD_TESTING "Build tests" OFF)
-project(absl LANGUAGES CXX)
+project(absl LANGUAGES CXX VERSION 20210324)
include(CTest)
# Output directory is correct by default for most build setups. However, when
@@ -144,17 +144,7 @@ endif()
add_subdirectory(absl)
if(ABSL_ENABLE_INSTALL)
- # absl:lts-remove-begin(system installation is supported for LTS releases)
- # We don't support system-wide installation
- list(APPEND SYSTEM_INSTALL_DIRS "/usr/local" "/usr" "/opt/" "/opt/local" "c:/Program Files/${PROJECT_NAME}")
- if(NOT DEFINED CMAKE_INSTALL_PREFIX OR CMAKE_INSTALL_PREFIX IN_LIST SYSTEM_INSTALL_DIRS)
- message(WARNING "\
- The default and system-level install directories are unsupported except in LTS \
- releases of Abseil. Please set CMAKE_INSTALL_PREFIX to install Abseil in your \
- source or build tree directly.\
- ")
- endif()
- # absl:lts-remove-end
+
# install as a subdirectory only
install(EXPORT ${PROJECT_NAME}Targets