summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@google.com>2020-09-14 17:39:03 -0400
committerGravatar Benjamin Barenblat <bbaren@google.com>2020-09-14 17:39:03 -0400
commitd7352d827df8f422eb55dc88448f346cafdb05e4 (patch)
tree56ca71abd9e083a78ec64b0c3d0fea5f7e3fcfba
parent3dc8d1e43262a739dc4c8ee4e45e4c45c6d9bdd8 (diff)
Fix CMake warning about finding module
CMake now warns if you include a module directly rather than using find_dependency. Apply a patch from upstream to fix the problem. Closes: https://bugs.debian.org/970333
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/bug970333.diff20
-rw-r--r--debian/patches/series1
3 files changed, 28 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 41a779f0..28a34e60 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+abseil (0~20200225.2-4) UNRELEASED; urgency=medium
+
+ * Fix "autopkgtest needs update for new version of cmake: warning on
+ stderr" by applying a patch from upstream. (Closes: #970333)
+
+ -- Benjamin Barenblat <bbaren@debian.org> Mon, 14 Sep 2020 17:38:40 -0400
+
abseil (0~20200225.2-3) unstable; urgency=medium
* Replace symbols file with shlibs infrastructure. (Closes: #966183)
diff --git a/debian/patches/bug970333.diff b/debian/patches/bug970333.diff
new file mode 100644
index 00000000..efca5a5a
--- /dev/null
+++ b/debian/patches/bug970333.diff
@@ -0,0 +1,20 @@
+From: Zach Toogood <zach@yousician.com>
+Subject: Fix CMake Threads dependency issue
+Origin: upstream, https://github.com/abseil/abseil-cpp/commit/68494aae959dfbbf781cdf03a988d2f5fc7e4802
+Bug: https://github.com/abseil/abseil-cpp/issues/668
+Bug-Debian: https://bugs.debian.org/970333
+
+Improve CMake support by finding the Threads module with find_dependency
+rather than trying to include it directly. This silences a CMake warning.
+
+--- a/CMake/abslConfig.cmake.in
++++ b/CMake/abslConfig.cmake.in
+@@ -1,6 +1,7 @@
+ # absl CMake configuration file.
+
+-include(FindThreads)
++include(CMakeFindDependencyMacro)
++find_dependency(Threads)
+
+ @PACKAGE_INIT@
+
diff --git a/debian/patches/series b/debian/patches/series
index f99c8e0c..f544d1d9 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,3 @@
license.diff
configure.diff
+bug970333.diff