summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@google.com>2021-04-08 11:26:40 -0400
committerGravatar Benjamin Barenblat <bbaren@google.com>2021-04-08 11:26:40 -0400
commit9c4d4dbaa118a180f6d0e681dfe89efd22ae1cf4 (patch)
treeb8e62acc78d63d8befbac5ac494fc2be9274b802
parent52366b8fe9dc581191540c99412f8447c9251701 (diff)
Install pkg-config files
Abseil now ships pkg-config files. Install them with libabsl-dev, using debhelper 13’s variable substitution support to handle multiarch. Expand libabsl-dev’ Recommends: cmake to Recommends: cmake | pkg-config to reflect the fact that it’s now reasonable to use Abseil without CMake.
-rw-r--r--debian/control4
-rw-r--r--debian/libabsl-dev.install1
2 files changed, 3 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index fdff44b6..3b8846f7 100644
--- a/debian/control
+++ b/debian/control
@@ -17,7 +17,7 @@ Priority: optional
Maintainer: Benjamin Barenblat <bbaren@debian.org>
Build-Depends:
cmake (>= 3.5),
- debhelper-compat (= 12),
+ debhelper-compat (= 13),
googletest (>= 1.10.0.20200926) [amd64 ppc64el],
Rules-Requires-Root: no
Standards-Version: 4.5.1
@@ -39,7 +39,7 @@ Section: libdevel
Depends:
libabsl20210324 (= ${binary:Version}),
${misc:Depends},
-Recommends: cmake (>= 2.6), g++ (>= 5.1)
+Recommends: cmake (>= 2.6) | pkg-config, g++ (>= 5.1)
Description: ${source:Synopsis} (development files)
${source:Extended-Description}
.
diff --git a/debian/libabsl-dev.install b/debian/libabsl-dev.install
index db5108c6..42e5174a 100644
--- a/debian/libabsl-dev.install
+++ b/debian/libabsl-dev.install
@@ -16,3 +16,4 @@ usr/include/absl
usr/lib/*/*.a
usr/lib/*/*.so
usr/lib/*/cmake
+usr/lib/pkgconfig/*.pc usr/lib/${DEB_HOST_MULTIARCH}/pkgconfig