summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Derek Mauro <761129+derekmauro@users.noreply.github.com>2024-07-22 12:23:21 -0400
committerGravatar GitHub <noreply@github.com>2024-07-22 12:23:21 -0400
commitebdba5af75fab91ebe9bc4daa0077f9c57c36692 (patch)
tree0e395099cf1a3c2347b3cba18eec7207d4ca25aa
parent3358286120d143e6a622652675b8b1b78447293c (diff)
Apply LTS transformations for 20240722 LTS branch (#1724)20240722.rc1
-rw-r--r--CMakeLists.txt16
-rw-r--r--MODULE.bazel2
-rw-r--r--absl/base/config.h4
-rw-r--r--absl/base/options.h4
4 files changed, 8 insertions, 18 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9d3e4f33..7c82b3a7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,8 +23,8 @@ if (POLICY CMP0141)
cmake_policy(SET CMP0141 NEW)
endif (POLICY CMP0141)
-project(absl LANGUAGES CXX)
-set(ABSL_SOVERSION 0)
+project(absl LANGUAGES CXX VERSION 20240722)
+set(ABSL_SOVERSION "2407.0.0")
include(CTest)
# Output directory is correct by default for most build setups. However, when
@@ -173,17 +173,7 @@ endif()
add_subdirectory(absl)
if(ABSL_ENABLE_INSTALL)
- # absl:lts-remove-begin(system installation is supported for LTS releases)
- # We don't support system-wide installation
- list(APPEND SYSTEM_INSTALL_DIRS "/usr/local" "/usr" "/opt/" "/opt/local" "c:/Program Files/${PROJECT_NAME}")
- if(NOT DEFINED CMAKE_INSTALL_PREFIX OR CMAKE_INSTALL_PREFIX IN_LIST SYSTEM_INSTALL_DIRS)
- message(WARNING "\
- The default and system-level install directories are unsupported except in LTS \
- releases of Abseil. Please set CMAKE_INSTALL_PREFIX to install Abseil in your \
- source or build tree directly.\
- ")
- endif()
- # absl:lts-remove-end
+
# install as a subdirectory only
install(EXPORT ${PROJECT_NAME}Targets
diff --git a/MODULE.bazel b/MODULE.bazel
index 973f31b3..08112b9a 100644
--- a/MODULE.bazel
+++ b/MODULE.bazel
@@ -16,7 +16,7 @@
module(
name = "abseil-cpp",
- version = "head",
+ version = "20240722.0",
compatibility_level = 1,
)
diff --git a/absl/base/config.h b/absl/base/config.h
index 97c9a22a..0b22167e 100644
--- a/absl/base/config.h
+++ b/absl/base/config.h
@@ -117,8 +117,8 @@
//
// LTS releases can be obtained from
// https://github.com/abseil/abseil-cpp/releases.
-#undef ABSL_LTS_RELEASE_VERSION
-#undef ABSL_LTS_RELEASE_PATCH_LEVEL
+#define ABSL_LTS_RELEASE_VERSION 20240722
+#define ABSL_LTS_RELEASE_PATCH_LEVEL 0
// Helper macro to convert a CPP variable to a string literal.
#define ABSL_INTERNAL_DO_TOKEN_STR(x) #x
diff --git a/absl/base/options.h b/absl/base/options.h
index a169658f..61a996b6 100644
--- a/absl/base/options.h
+++ b/absl/base/options.h
@@ -225,8 +225,8 @@
// be changed to a new, unique identifier name. In particular "head" is not
// allowed.
-#define ABSL_OPTION_USE_INLINE_NAMESPACE 0
-#define ABSL_OPTION_INLINE_NAMESPACE_NAME head
+#define ABSL_OPTION_USE_INLINE_NAMESPACE 1
+#define ABSL_OPTION_INLINE_NAMESPACE_NAME lts_20240722
// ABSL_OPTION_HARDENED
//