summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Mizux <corentinl@google.com>2020-07-09 18:41:57 +0200
committerGravatar GitHub <noreply@github.com>2020-07-09 12:41:57 -0400
commit63f2c695ed1b35dfe609c630d9210049eb611b8e (patch)
treef7b05c7d069d6f8996f1ce9ea60d854c70dbdb22
parent23f1f9cf6d02f834d55c0595566c0d607d4c5ed8 (diff)
cmake: flag conformance_testing as TESTONLY (#737)
All libraries depending on any gmock target should be flagged as TESTONLY
-rw-r--r--absl/types/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/absl/types/CMakeLists.txt b/absl/types/CMakeLists.txt
index 0dc0d2c7..3f99ad8a 100644
--- a/absl/types/CMakeLists.txt
+++ b/absl/types/CMakeLists.txt
@@ -259,7 +259,7 @@ absl_cc_library(
absl::strings
absl::utility
gmock_main
- PUBLIC
+ TESTONLY
)
absl_cc_test(