summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Abseil Team <absl-team@google.com>2020-05-28 12:55:24 -0700
committerGravatar Derek Mauro <dmauro@google.com>2020-05-28 15:58:09 -0400
commit2069dc796aa255f7c82861c6e83b82d001ceef4a (patch)
treea380c9d6c1890b2b67cd77625d404ac9e141a415
parent4832bf6bf27b873cffc020f4b4f85634d11c57be (diff)
Export of internal Abseil changes
-- cb68208c1ae9ca45ce48bf2b7e6cc46592a3b22d by Derek Mauro <dmauro@google.com>: Update GoogleTest dependency and use it to mark a parameterized test as possibly unused. PiperOrigin-RevId: 313643136 -- 24f61fe25e943e78f8a1fd014c89516776943170 by Derek Mauro <dmauro@google.com>: Internal change PiperOrigin-RevId: 313636155 -- 36c453ddf04791f8cf3d14673bacd7bbd98911fd by Gennadiy Rozental <rogeeff@google.com>: Address sanitizer should not use DYNAMIC_ANNOTATIONS_ENABLED=1 PiperOrigin-RevId: 313635651 -- 7a7a3e3888ac8ae366572ea0a2a1c62dc669cec7 by Abseil Team <absl-team@google.com>: CMake: don't attempt to use googletest unless ABSL_RUN_TESTS==true. Fixes: https://github.com/abseil/abseil-cpp/issues/690 PiperOrigin-RevId: 313477705 GitOrigin-RevId: cb68208c1ae9ca45ce48bf2b7e6cc46592a3b22d Change-Id: Ief7b31b53cdf3f79518b767d882960c1636aad23
-rw-r--r--BUILD.bazel2
-rw-r--r--CMakeLists.txt4
-rw-r--r--WORKSPACE8
-rw-r--r--absl/container/internal/unordered_map_modifiers_test.h2
-rwxr-xr-xci/linux_clang-latest_libcxx_asan_bazel.sh1
5 files changed, 8 insertions, 9 deletions
diff --git a/BUILD.bazel b/BUILD.bazel
index 0d14d4d1..79fb0ecd 100644
--- a/BUILD.bazel
+++ b/BUILD.bazel
@@ -20,6 +20,6 @@ licenses(["notice"]) # Apache 2.0
# Expose license for external usage through bazel.
exports_files([
- "LICENSE",
"AUTHORS",
+ "LICENSE",
])
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 47670454..c654c892 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -99,10 +99,8 @@ if(${ABSL_RUN_TESTS})
# on the command line
include(CTest)
enable_testing()
-endif()
-## check targets
-if(BUILD_TESTING)
+ ## check targets
if (NOT ABSL_USE_EXTERNAL_GOOGLETEST)
set(absl_gtest_build_dir ${CMAKE_BINARY_DIR}/googletest-build)
if(${ABSL_USE_GOOGLETEST_HEAD})
diff --git a/WORKSPACE b/WORKSPACE
index f2b10464..1a1da6c5 100644
--- a/WORKSPACE
+++ b/WORKSPACE
@@ -19,10 +19,10 @@ load("@bazel_tools//tools/build_defs/repo:http.bzl", "http_archive")
# GoogleTest/GoogleMock framework. Used by most unit-tests.
http_archive(
- name = "com_google_googletest",
- urls = ["https://github.com/google/googletest/archive/b6cd405286ed8635ece71c72f118e659f4ade3fb.zip"], # 2019-01-07
- strip_prefix = "googletest-b6cd405286ed8635ece71c72f118e659f4ade3fb",
- sha256 = "ff7a82736e158c077e76188232eac77913a15dac0b22508c390ab3f88e6d6d86",
+ name = "com_google_googletest",
+ urls = ["https://github.com/google/googletest/archive/011959aafddcd30611003de96cfd8d7a7685c700.zip"], # 2020-05-14T00:36:05Z
+ strip_prefix = "googletest-011959aafddcd30611003de96cfd8d7a7685c700",
+ sha256 = "6a5d7d63cd6e0ad2a7130471105a3b83799a7a2b14ef7ec8d742b54f01a4833c",
)
# Google benchmark.
diff --git a/absl/container/internal/unordered_map_modifiers_test.h b/absl/container/internal/unordered_map_modifiers_test.h
index b8c513f1..8c9ca779 100644
--- a/absl/container/internal/unordered_map_modifiers_test.h
+++ b/absl/container/internal/unordered_map_modifiers_test.h
@@ -286,6 +286,8 @@ class UniquePtrModifiersTest : public ::testing::Test {
}
};
+GTEST_ALLOW_UNINSTANTIATED_PARAMETERIZED_TEST(UniquePtrModifiersTest);
+
TYPED_TEST_SUITE_P(UniquePtrModifiersTest);
// Test that we do not move from rvalue arguments if an insertion does not
diff --git a/ci/linux_clang-latest_libcxx_asan_bazel.sh b/ci/linux_clang-latest_libcxx_asan_bazel.sh
index 44794eb5..0c250a62 100755
--- a/ci/linux_clang-latest_libcxx_asan_bazel.sh
+++ b/ci/linux_clang-latest_libcxx_asan_bazel.sh
@@ -78,7 +78,6 @@ for std in ${STD}; do
/usr/local/bin/bazel test ... \
--compilation_mode="${compilation_mode}" \
--copt="${exceptions_mode}" \
- --copt="-DDYNAMIC_ANNOTATIONS_ENABLED=1" \
--copt="-DADDRESS_SANITIZER" \
--copt="-DUNDEFINED_BEHAVIOR_SANITIZER" \
--copt="-fsanitize=address" \