summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules32
1 files changed, 32 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..e705617
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,32 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+include /usr/share/coq/coqvars.mk
+include /usr/share/ocaml/ocamlvars.mk
+
+ifeq ($(OCAML_NATDYNLINK),yes)
+ TARGET := opt
+else
+ TARGET := byte
+endif
+
+%:
+ dh $@ --with ocaml
+
+.PHONY: override_dh_auto_build
+override_dh_auto_build:
+ $(MAKE) Makefile.coq
+ $(MAKE) -f Makefile.coq $(TARGET) html
+
+.PHONY: override_dh_auto_install
+override_dh_auto_install:
+ $(MAKE) -f Makefile.coq install DSTROOT=$(CURDIR)/debian/tmp
+
+.PHONY: override_dh_install
+override_dh_install:
+ find debian/tmp -type f -name '*.glob' -delete
+ dh_install --fail-missing
+
+.PHONY: override_dh_gencontrol
+override_dh_gencontrol:
+ dh_gencontrol -- -VF:CoqABI="$(COQ_ABI)"