summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules27
1 files changed, 27 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..da4c4c4
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,27 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+include /usr/share/coq/coqvars.mk
+
+%:
+ dh $@ --with ocaml
+
+.PHONY: override_dh_auto_configure
+override_dh_auto_configure:
+ ./make_makefile
+
+.PHONY: override_dh_auto_build
+override_dh_auto_build:
+ $(MAKE) world
+
+.PHONY: override_dh_auto_install
+override_dh_auto_install:
+# install rule as generated by coq_makefile is buggy
+
+.PHONY: override_dh_gencontrol
+override_dh_gencontrol:
+ dh_gencontrol -- -VF:CoqABI="$(COQ_ABI)"
+
+.PHONY: override_dh_auto_clean
+override_dh_auto_clean:
+ rm -Rf .depend *.glob *.d *.*o *.*a *.cm* doc html