summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Benjamin Barenblat <bbaren@google.com>2019-02-13 21:08:16 -0500
committerGravatar Benjamin Barenblat <bbaren@google.com>2019-02-17 16:45:25 -0500
commitd10b86dc97e91ceb15134cc190d6f647a7c3d640 (patch)
treea3b392da3971639beb3b1ee3eceb9406e8148cab
parentac180116ee6094d9baf5f0fc0965a377e9560504 (diff)
Ensure both bytecode and native code builds on native-code platforms
coq_makefile from Coq 8.9 does not automatically build bytecode when native code is available. Forcibly build both on native-code platforms.
-rwxr-xr-xdebian/rules9
1 files changed, 5 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index cc3a662..c235160 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,10 +7,11 @@ include /usr/share/ocaml/ocamlvars.mk
# Show full commands when building.
export VERBOSE := 1
+TARGET := byte
+INSTALL_TARGET := install-byte
ifeq ($(OCAML_NATDYNLINK),yes)
- TARGET := opt
-else
- TARGET := byte
+ TARGET += opt
+ INSTALL_TARGET += install
endif
%:
@@ -27,7 +28,7 @@ override_dh_auto_build:
.PHONY: override_dh_auto_install
override_dh_auto_install:
- $(MAKE) -f Makefile.coq install DSTROOT=$(CURDIR)/debian/tmp
+ $(MAKE) -f Makefile.coq $(INSTALL_TARGET) DSTROOT=$(CURDIR)/debian/tmp
.PHONY: override_dh_install
override_dh_install: