aboutsummaryrefslogtreecommitdiffhomepage
path: root/distrib/RH/coq.spec
diff options
context:
space:
mode:
Diffstat (limited to 'distrib/RH/coq.spec')
-rw-r--r--distrib/RH/coq.spec9
1 files changed, 5 insertions, 4 deletions
diff --git a/distrib/RH/coq.spec b/distrib/RH/coq.spec
index 89536cb83..c8945b4fa 100644
--- a/distrib/RH/coq.spec
+++ b/distrib/RH/coq.spec
@@ -26,15 +26,15 @@ Coq is a proof assistant which:
%setup
%build
-./configure -prefix /usr -emacs emacs -emacslib /usr/share/emacs/site-lisp -opt -reals all -coqide no # Need ocamlc.opt and ocamlopt.opt
-make coq # Use native coq to compile theories
+./configure -prefix /usr -emacslib /usr/share/emacs/site-lisp -opt -reals all -coqide no # Need ocamlc.opt and ocamlopt.opt
+make coq # Use native coq to compile theories
%clean
make clean
%install
-make -e COQINSTALLPREFIX=$RPM_BUILD_ROOT/ BASETEXDIR=$RPM_BUILD_ROOT/ install-coq
+make -e COQINSTALLPREFIX=$RPM_BUILD_ROOT/ install-coq
# To install only locally the binaries compiled with absolute paths
%post
@@ -52,7 +52,8 @@ if [ -L /usr/local/lib/ocaml ]; then
rm /usr/local/lib/ocaml
fi
-# the spec file is moved to distrib/RH/src/SPECS but coq.list is in distrib/RH
+# the spec file is read from distrib/RH/src/SOURCES/coqX.Y
+# but coq.list is in distrib/RH/src
%files -f ../../coq.list
%defattr(-,root,root)