aboutsummaryrefslogtreecommitdiffhomepage
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix11
1 files changed, 9 insertions, 2 deletions
diff --git a/default.nix b/default.nix
index eec82624d..9d93abe74 100644
--- a/default.nix
+++ b/default.nix
@@ -21,8 +21,15 @@
# Once the build is finished, you will find, in the current directory,
# a symlink to where Coq was installed.
-{ pkgs ? (import <nixpkgs> {}), ocamlPackages ? pkgs.ocamlPackages,
- buildIde ? true, buildDoc ? true, doCheck ? true }:
+{ pkgs ?
+ (import (fetchTarball
+ "https://github.com/NixOS/nixpkgs/archive/4345a2cef228a91c1d6d4bf626a0f933eb8cc4f9.tar.gz")
+ {})
+, ocamlPackages ? pkgs.ocamlPackages
+, buildIde ? true
+, buildDoc ? true
+, doCheck ? true
+}:
with pkgs;