aboutsummaryrefslogtreecommitdiffhomepage
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix12
1 files changed, 4 insertions, 8 deletions
diff --git a/default.nix b/default.nix
index d5e7674d4..2bf0409d6 100644
--- a/default.nix
+++ b/default.nix
@@ -40,9 +40,9 @@ stdenv.mkDerivation rec {
name = "coq";
buildInputs = [
-
- # Coq dependencies
hostname
+ python2 time # coq-makefile timing tools
+
] ++ (with ocamlPackages; [
ocaml
findlib
@@ -67,13 +67,9 @@ stdenv.mkDerivation rec {
# Test-suite dependencies
# ncurses is required to build an OCaml REPL
optional (!versionAtLeast ocaml.version "4.07") ncurses
- ++ [
- python2
- rsync
- which
- ocamlPackages.ounit
+ ++ [ ocamlPackages.ounit rsync which ]
- ] else []) ++ (if lib.inNixShell then [
+ else []) ++ (if lib.inNixShell then [
ocamlPackages.merlin
ocamlPackages.ocp-indent
ocamlPackages.ocp-index