aboutsummaryrefslogtreecommitdiffhomepage
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix11
1 files changed, 10 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index af2a13a84..2011bf574 100644
--- a/default.nix
+++ b/default.nix
@@ -22,7 +22,7 @@
# a symlink to where Coq was installed.
{ pkgs ? (import <nixpkgs> {}), ocamlPackages ? pkgs.ocamlPackages,
- buildIde ? true, doCheck ? true }:
+ buildIde ? true, buildDoc ? true, doCheck ? true }:
with pkgs;
@@ -43,6 +43,15 @@ stdenv.mkDerivation rec {
# CoqIDE dependencies
ocamlPackages.lablgtk
+ ] else []) ++ (if buildDoc then [
+
+ # Sphinx doc dependencies
+ ocamlPackages.lablgtk
+ pkgconfig (python3.withPackages
+ (ps: [ ps.sphinx ps.sphinx_rtd_theme ps.pexpect ps.beautifulsoup4
+ ps.antlr4-python3-runtime ps.sphinxcontrib-bibtex ]))
+ antlr4
+
] else []) ++ (if doCheck then
# Test-suite dependencies