aboutsummaryrefslogtreecommitdiffhomepage
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/default.nix b/default.nix
index c791706db..d9317bcca 100644
--- a/default.nix
+++ b/default.nix
@@ -30,6 +30,9 @@
, buildIde ? true
, buildDoc ? true
, doInstallCheck ? true
+, shell ? false
+ # We don't use lib.inNixShell because that would also apply
+ # when in a nix-shell of some package depending on this one.
}:
with pkgs;
@@ -58,13 +61,13 @@ stdenv.mkDerivation rec {
optional (!versionAtLeast ocaml.version "4.07") ncurses
++ [ ocamlPackages.ounit rsync which ]
)
- ++ optionals lib.inNixShell (
+ ++ optionals shell (
[ jq curl git gnupg ] # Dependencies of the merging script
++ (with ocamlPackages; [ merlin ocp-indent ocp-index ]) # Dev tools
);
src =
- if lib.inNixShell then null
+ if shell then null
else
with builtins; filterSource
(path: _: