aboutsummaryrefslogtreecommitdiffhomepage
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix26
1 files changed, 24 insertions, 2 deletions
diff --git a/default.nix b/default.nix
index af2a13a84..26c6e4b90 100644
--- a/default.nix
+++ b/default.nix
@@ -21,8 +21,15 @@
# Once the build is finished, you will find, in the current directory,
# a symlink to where Coq was installed.
-{ pkgs ? (import <nixpkgs> {}), ocamlPackages ? pkgs.ocamlPackages,
- buildIde ? true, doCheck ? true }:
+{ pkgs ?
+ (import (fetchTarball
+ "https://github.com/NixOS/nixpkgs/archive/4345a2cef228a91c1d6d4bf626a0f933eb8cc4f9.tar.gz")
+ {})
+, ocamlPackages ? pkgs.ocamlPackages
+, buildIde ? true
+, buildDoc ? true
+, doCheck ? true
+}:
with pkgs;
@@ -43,6 +50,14 @@ stdenv.mkDerivation rec {
# CoqIDE dependencies
ocamlPackages.lablgtk
+ ] else []) ++ (if buildDoc then [
+
+ # Sphinx doc dependencies
+ pkgconfig (python3.withPackages
+ (ps: [ ps.sphinx ps.sphinx_rtd_theme ps.pexpect ps.beautifulsoup4
+ ps.antlr4-python3-runtime ps.sphinxcontrib-bibtex ]))
+ antlr4
+
] else []) ++ (if doCheck then
# Test-suite dependencies
@@ -58,6 +73,13 @@ stdenv.mkDerivation rec {
ocamlPackages.merlin
ocamlPackages.ocpIndent
ocamlPackages.ocp-index
+
+ # Dependencies of the merging script
+ jq
+ curl
+ git
+ gnupg
+
] else []);
src =