aboutsummaryrefslogtreecommitdiffhomepage
path: root/distrib/debian/rules
diff options
context:
space:
mode:
authorGravatar courant <courant@85f007b7-540e-0410-9357-904b9bb8a0f7>2001-12-21 13:07:08 +0000
committerGravatar courant <courant@85f007b7-540e-0410-9357-904b9bb8a0f7>2001-12-21 13:07:08 +0000
commit36c5fed3457e51adc6481826bfd74e7d1f73d274 (patch)
treefcf7173dbdc6fefb68268c5b309fe3517a5cc174 /distrib/debian/rules
parent8e8e5aaa7320c56dc7128f92a72669c0be684e78 (diff)
paquet Debian
git-svn-id: svn+ssh://scm.gforge.inria.fr/svn/coq/trunk@2360 85f007b7-540e-0410-9357-904b9bb8a0f7
Diffstat (limited to 'distrib/debian/rules')
-rwxr-xr-xdistrib/debian/rules29
1 files changed, 1 insertions, 28 deletions
diff --git a/distrib/debian/rules b/distrib/debian/rules
index a584b2ebb..3c1a89263 100755
--- a/distrib/debian/rules
+++ b/distrib/debian/rules
@@ -1,29 +1,17 @@
#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-# This is the debhelper compatability version to use.
export DH_COMPAT=3
configure: configure-stamp
configure-stamp:
dh_testdir
- # Add here commands to configure the package.
./configure --prefix /usr --mandir /usr/share/man --emacslib /usr/share/emacs/site-lisp/coq
-
touch configure-stamp
build: configure-stamp build-stamp
build-stamp:
dh_testdir
-
- # Add here commands to compile the package.
$(MAKE) world || (echo WARNING: NATIVE CODE COMPILATION FAILED && echo Trying to build coq in bytecode && echo "OPT=byte" >> config/Makefile && $(MAKE) world)
- #/usr/bin/docbook-to-man debian/coq.sgml > coq.1
-
touch build-stamp
clean:
@@ -31,7 +19,6 @@ clean:
dh_testroot
rm -f build-stamp configure-stamp
- # Add here commands to clean up after the build process.
-$(MAKE) clean
-$(MAKE) archclean
@@ -43,8 +30,8 @@ install: build
dh_clean -k
dh_installdirs
- # Add here commands to install the package into debian/coq.
$(MAKE) install COQINSTALLPREFIX=$(CURDIR)/debian/coq
+ -strip -R .note -R .comment $(CURDIR)/debian/coq/usr/bin/coqtop.opt
# Build architecture-independent files here.
binary-indep: build install
@@ -54,27 +41,13 @@ binary-indep: build install
binary-arch: build install
dh_testdir
dh_testroot
-# dh_installdebconf
dh_installdocs
-# dh_installexamples
-# dh_installmenu
-# dh_installlogrotate
dh_installemacsen
-# dh_installpam
-# dh_installmime
-# dh_installinit
-# dh_installcron
-# dh_installman coqtop.byte coqtop.opt coqtop coqc coqmktop
-# dh_installinfo
-# dh_undocumented
dh_installchangelogs CHANGES
dh_link
-# dh_strip
dh_compress
dh_fixperms
-# dh_makeshlibs
dh_installdeb
-# dh_perl
dh_shlibdeps
dh_gencontrol
dh_md5sums