aboutsummaryrefslogtreecommitdiffhomepage
path: root/default.nix
diff options
context:
space:
mode:
authorGravatar Vincent Laporte <Vincent.Laporte@gmail.com>2018-03-09 16:01:47 +0000
committerGravatar Vincent Laporte <Vincent.Laporte@gmail.com>2018-03-09 16:11:30 +0000
commit8fee0fdcb0e9021ee3427cffcba4e77c6a6e3bc9 (patch)
tree60ad9b19eedd3c63185fa2cada5ed02b1857f07c /default.nix
parentd7232032b3d25e965c5265c5453fc609833317b5 (diff)
[default.nix] Pin nixpkgs version to include Sphinx dependencies
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix11
1 files changed, 9 insertions, 2 deletions
diff --git a/default.nix b/default.nix
index eec82624d..9d93abe74 100644
--- a/default.nix
+++ b/default.nix
@@ -21,8 +21,15 @@
# Once the build is finished, you will find, in the current directory,
# a symlink to where Coq was installed.
-{ pkgs ? (import <nixpkgs> {}), ocamlPackages ? pkgs.ocamlPackages,
- buildIde ? true, buildDoc ? true, doCheck ? true }:
+{ pkgs ?
+ (import (fetchTarball
+ "https://github.com/NixOS/nixpkgs/archive/4345a2cef228a91c1d6d4bf626a0f933eb8cc4f9.tar.gz")
+ {})
+, ocamlPackages ? pkgs.ocamlPackages
+, buildIde ? true
+, buildDoc ? true
+, doCheck ? true
+}:
with pkgs;