aboutsummaryrefslogtreecommitdiffhomepage
path: root/default.nix
diff options
context:
space:
mode:
authorGravatar Théo Zimmermann <theo.zimmermann@univ-paris-diderot.fr>2018-04-17 13:11:52 +0200
committerGravatar Théo Zimmermann <theo.zimmermann@univ-paris-diderot.fr>2018-04-17 22:54:50 +0200
commit53794457f39ff07a59c4a1229180bd64c18631c1 (patch)
tree0310f3c213d23e06f53b50194a62344e0f4f40c7 /default.nix
parenta34bd320aed7027c46021643cd2495baa0a17089 (diff)
[default.nix] Build doc with nix-build.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix8
1 files changed, 6 insertions, 2 deletions
diff --git a/default.nix b/default.nix
index 26c6e4b90..0b4794274 100644
--- a/default.nix
+++ b/default.nix
@@ -32,6 +32,7 @@
}:
with pkgs;
+with stdenv.lib;
stdenv.mkDerivation rec {
@@ -61,8 +62,7 @@ stdenv.mkDerivation rec {
] else []) ++ (if doCheck then
# Test-suite dependencies
- let inherit (stdenv.lib) versionAtLeast optional; in
- /* ncurses is required to build an OCaml REPL */
+ # ncurses is required to build an OCaml REPL
optional (!versionAtLeast ocaml.version "4.07") ncurses
++ [
python
@@ -90,6 +90,10 @@ stdenv.mkDerivation rec {
prefixKey = "-prefix ";
+ buildFlags = optionals buildDoc [ "world" "sphinx" ];
+
+ installTargets = [ "install" ] ++ optional buildDoc "install-doc-sphinx";
+
inherit doCheck;
}