aboutsummaryrefslogtreecommitdiffhomepage
path: root/default.nix
diff options
context:
space:
mode:
authorGravatar Théo Zimmermann <theo.zimmermann@univ-paris-diderot.fr>2018-07-03 11:34:18 +0200
committerGravatar Théo Zimmermann <theo.zimmermann@univ-paris-diderot.fr>2018-07-03 23:57:50 +0200
commit5239af30618d3c23666cc75078bf269172b6d3df (patch)
treeda76e3bf1077f0a377d3f2782d57c206a355dbd8 /default.nix
parent89d8674c6ac2c826f157ff0a007cc5eecda9b313 (diff)
Fix timing tools on NixOS.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix12
1 files changed, 4 insertions, 8 deletions
diff --git a/default.nix b/default.nix
index d5e7674d4..2bf0409d6 100644
--- a/default.nix
+++ b/default.nix
@@ -40,9 +40,9 @@ stdenv.mkDerivation rec {
name = "coq";
buildInputs = [
-
- # Coq dependencies
hostname
+ python2 time # coq-makefile timing tools
+
] ++ (with ocamlPackages; [
ocaml
findlib
@@ -67,13 +67,9 @@ stdenv.mkDerivation rec {
# Test-suite dependencies
# ncurses is required to build an OCaml REPL
optional (!versionAtLeast ocaml.version "4.07") ncurses
- ++ [
- python2
- rsync
- which
- ocamlPackages.ounit
+ ++ [ ocamlPackages.ounit rsync which ]
- ] else []) ++ (if lib.inNixShell then [
+ else []) ++ (if lib.inNixShell then [
ocamlPackages.merlin
ocamlPackages.ocp-indent
ocamlPackages.ocp-index