aboutsummaryrefslogtreecommitdiffhomepage
path: root/default.nix
diff options
context:
space:
mode:
authorGravatar Maxime Dénès <mail@maximedenes.fr>2017-02-10 15:52:24 +0100
committerGravatar Maxime Dénès <mail@maximedenes.fr>2018-03-09 15:12:51 +0100
commit4aaf28cc905bebf757b02ad911a6eed78714cac7 (patch)
tree91322ece8b35fc82247938d8a5dc0e70cd22597b /default.nix
parent1505304e856091e10ff3511edecb9cf7c20974b2 (diff)
Integration of a sphinx-based documentation generator.
The original contribution is from Clément Pit-Claudel. I updated his code and integrated it with the Coq build system. Many improvements by Paul Steckler (MIT). This commit adds the infrastructure but no content.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix11
1 files changed, 10 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index af2a13a84..2011bf574 100644
--- a/default.nix
+++ b/default.nix
@@ -22,7 +22,7 @@
# a symlink to where Coq was installed.
{ pkgs ? (import <nixpkgs> {}), ocamlPackages ? pkgs.ocamlPackages,
- buildIde ? true, doCheck ? true }:
+ buildIde ? true, buildDoc ? true, doCheck ? true }:
with pkgs;
@@ -43,6 +43,15 @@ stdenv.mkDerivation rec {
# CoqIDE dependencies
ocamlPackages.lablgtk
+ ] else []) ++ (if buildDoc then [
+
+ # Sphinx doc dependencies
+ ocamlPackages.lablgtk
+ pkgconfig (python3.withPackages
+ (ps: [ ps.sphinx ps.sphinx_rtd_theme ps.pexpect ps.beautifulsoup4
+ ps.antlr4-python3-runtime ps.sphinxcontrib-bibtex ]))
+ antlr4
+
] else []) ++ (if doCheck then
# Test-suite dependencies