aboutsummaryrefslogtreecommitdiffhomepage
path: root/default.nix
diff options
context:
space:
mode:
authorGravatar Théo Zimmermann <theo.zimmermann@univ-paris-diderot.fr>2018-07-05 09:46:26 +0200
committerGravatar Théo Zimmermann <theo.zimmermann@univ-paris-diderot.fr>2018-07-05 17:48:03 +0200
commit1f9be66ae0a4510f3564c8ed2add9b0228407f01 (patch)
tree0ad797ea49e169b50838e4e2f38cd6739d072b0b /default.nix
parent15b1a9e73a83350041cec076190f8344e759d0ed (diff)
[pkg:nix] Pass through the ocamlPackages version used to build.
This will be useful for users wanting to build a plugin using this package.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index 1be274081..c791706db 100644
--- a/default.nix
+++ b/default.nix
@@ -86,4 +86,18 @@ stdenv.mkDerivation rec {
installCheckTarget = [ "check" ];
+ passthru = { inherit ocamlPackages; };
+
+ meta = {
+ description = "Coq proof assistant";
+ longDescription = ''
+ Coq is a formal proof management system. It provides a formal language
+ to write mathematical definitions, executable algorithms and theorems
+ together with an environment for semi-interactive development of
+ machine-checked proofs.
+ '';
+ homepage = http://coq.inria.fr;
+ license = licenses.lgpl21;
+ };
+
}