aboutsummaryrefslogtreecommitdiffhomepage
path: root/default.nix
diff options
context:
space:
mode:
authorGravatar Vincent Laporte <Vincent.Laporte@gmail.com>2017-12-05 13:14:17 +0000
committerGravatar Vincent Laporte <Vincent.Laporte@gmail.com>2017-12-05 13:14:17 +0000
commit1acd714b2b0253aae05af534f3c7f7c0e726617a (patch)
tree260ed23a54a2b05311265b0072b87b7050899ad3 /default.nix
parent359119ff1389d489454d2d55fc5d23e9e71c2daf (diff)
[default.nix] explain ncurses dependency
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/default.nix b/default.nix
index 6d50fb4d9..f78785a1f 100644
--- a/default.nix
+++ b/default.nix
@@ -42,10 +42,13 @@ stdenv.mkDerivation rec {
# CoqIDE dependencies
ocamlPackages.lablgtk
- ] else []) ++ (if doCheck then [
+ ] else []) ++ (if doCheck then
# Test-suite dependencies
- ncurses
+ let inherit (stdenv.lib) versionAtLeast optional; in
+ /* ncurses is required to build an OCaml REPL */
+ optional (!versionAtLeast ocaml.version "4.07") ncurses
+ ++ [
python
rsync
which