aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/common/CMakeLists.txt')
-rw-r--r--src/common/CMakeLists.txt14
1 files changed, 10 insertions, 4 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index 9d5a9076..3c3419bb 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -3,14 +3,15 @@ configure_file("${CMAKE_CURRENT_SOURCE_DIR}/scm_rev.cpp.in" "${CMAKE_CURRENT_SOU
set(SRCS
break_points.cpp
- console_listener.cpp
emu_window.cpp
extended_trace.cpp
file_search.cpp
file_util.cpp
hash.cpp
key_map.cpp
- log_manager.cpp
+ logging/filter.cpp
+ logging/text_formatter.cpp
+ logging/backend.cpp
math_util.cpp
mem_arena.cpp
memory_util.cpp
@@ -32,7 +33,7 @@ set(HEADERS
common_funcs.h
common_paths.h
common_types.h
- console_listener.h
+ concurrent_ring_buffer.h
cpu_detect.h
debug_interface.h
emu_window.h
@@ -44,13 +45,18 @@ set(HEADERS
key_map.h
linear_disk_cache.h
log.h
- log_manager.h
+ logging/text_formatter.h
+ logging/filter.h
+ logging/log.h
+ logging/backend.h
+ make_unique.h
math_util.h
mem_arena.h
memory_util.h
msg_handler.h
platform.h
scm_rev.h
+ scope_exit.h
string_util.h
swap.h
symbols.h