aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/common/CMakeLists.txt')
-rw-r--r--src/common/CMakeLists.txt40
1 files changed, 39 insertions, 1 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index 5eaf6736..48f30de4 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -19,4 +19,42 @@ set(SRCS break_points.cpp
timer.cpp
utf8.cpp)
-add_library(common STATIC ${SRCS})
+set(HEADS atomic.h
+ atomic_gcc.h
+ atomic_win32.h
+ break_points.h
+ chunk_file.h
+ common_funcs.h
+ common_paths.h
+ common_types.h
+ common.h
+ console_listener.h
+ cpu_detect.h
+ debug_interface.h
+ emu_window.h
+ extended_trace.h
+ fifo_queue.h
+ file_search.h
+ file_util.h
+ hash.h
+ linear_disk_cache.h
+ log_manager.h
+ log.h
+ math_util.h
+ mem_arena.h
+ memory_util.h
+ msg_handler.h
+ platform.h
+ scm_rev.h
+ std_condition_variable.h
+ std_mutex.h
+ std_thread.h
+ string_util.h
+ swap.h
+ symbols.h
+ thread.h
+ thunk.h
+ timer.h
+ utf8.h)
+
+add_library(common STATIC ${SRCS} ${HEADS})