aboutsummaryrefslogtreecommitdiffhomepage
path: root/externals/getopt/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'externals/getopt/CMakeLists.txt')
-rw-r--r--externals/getopt/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/externals/getopt/CMakeLists.txt b/externals/getopt/CMakeLists.txt
new file mode 100644
index 00000000..c8b745d5
--- /dev/null
+++ b/externals/getopt/CMakeLists.txt
@@ -0,0 +1,11 @@
+set(SRCS
+ getopt.c
+ )
+set(HEADERS
+ getopt.h
+ )
+
+create_directory_groups(${SRCS} ${HEADERS})
+add_library(getopt ${SRCS} ${HEADERS})
+target_compile_definitions(getopt PUBLIC STATIC_GETOPT)
+target_include_directories(getopt INTERFACE ${CMAKE_CURRENT_SOURCE_DIR})