aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt27
1 files changed, 25 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0e48645d..5bb87d50 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,13 +12,34 @@ else()
add_definitions(/D_CRT_SECURE_NO_WARNINGS)
# set up output paths for executable binaries (.exe-files, and .dll-files on DLL-capable platforms)
set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin)
+
+ # Tweak optimization settings
+ # As far as I can tell, there's no way to override the CMake defaults while leaving user
+ # changes intact, so we'll just clobber everything and say sorry.
+ message(STATUS "Cache compiler flags ignored, please edit CMakeFiles.txt to change the flags.")
+ # /MD - Multi-threaded runtime
+ # /Ox - Full optimization
+ # /Oi - Use intrinsic functions
+ # /Oy- - Don't omit frame pointer
+ # /GR- - Disable RTTI
+ # /GS- - No stack buffer overflow checks
+ # /EHsc - C++-only exception handling semantics
+ set(optimization_flags "/MD /Ox /Oi /Oy- /DNDEBUG /GR- /GS- /EHsc")
+ # /Zi - Output debugging information
+ # /Zo - enahnced debug info for optimized builds
+ set(CMAKE_C_FLAGS_RELEASE "${optimization_flags} /Zi" CACHE STRING "" FORCE)
+ set(CMAKE_CXX_FLAGS_RELEASE "${optimization_flags} /Zi" CACHE STRING "" FORCE)
+ set(CMAKE_C_FLAGS_RELWITHDEBINFO "${optimization_flags} /Zi /Zo" CACHE STRING "" FORCE)
+ set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "${optimization_flags} /Zi /Zo" CACHE STRING "" FORCE)
endif()
add_definitions(-DSINGLETHREADED)
-find_package(PNG)
+find_package(PNG QUIET)
if (PNG_FOUND)
add_definitions(-DHAVE_PNG)
-endif ()
+else()
+ message(STATUS "libpng not found. Some debugging features have been disabled.")
+endif()
find_package(Boost)
if (Boost_FOUND)
@@ -138,6 +159,8 @@ set(INI_PREFIX "${CMAKE_CURRENT_SOURCE_DIR}/externals/inih")
include_directories(${INI_PREFIX})
add_subdirectory(${INI_PREFIX})
+include_directories(externals/nihstro/include)
+
# process subdirectories
if(ENABLE_QT)
include_directories(externals/qhexedit)