aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Greg Wicks <gpwicks@email.wm.edu>2015-06-22 20:59:00 -0400
committerGravatar Greg Wicks <gpwicks@email.wm.edu>2015-07-12 15:49:23 -0400
commit9930ef72ddaf8930a9bf3e574b7de69f73ecbf87 (patch)
tree30af5b4937f81d1ea7bb9148ec27e71d5501d345 /CMakeLists.txt
parentf4e1d8ea36fc3f8309234b8a4a8c9f659b171c80 (diff)
Implement new argument parsing using getopt and add the corresponding library to externals
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3658ef48..59f76fa9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -203,6 +203,10 @@ add_subdirectory(${INI_PREFIX})
include_directories(externals/nihstro/include)
+if (MSVC)
+ add_subdirectory(externals/getopt)
+endif()
+
# process subdirectories
if(ENABLE_QT)
include_directories(externals/qhexedit)