aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Subv <subv2112@gmail.com>2014-12-01 18:48:27 -0500
committerGravatar Subv <subv2112@gmail.com>2014-12-01 18:48:27 -0500
commit8712c9dcd6df69866248328ab37c1e1b986d94bd (patch)
tree319f45d5fc8dc02d0513a74edaa9bfbfbcebbdc7 /CMakeLists.txt
parentd5be332d21a24776aca917e5fcf747eed32ae543 (diff)
CMake: Place all the built files in BUILD_DIR/bin/<Configuration> when compiling with MSVC
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bbe9f76c..05a56040 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,6 +9,8 @@ if (NOT MSVC)
else()
# Silence deprecation warnings
add_definitions(/D_CRT_SECURE_NO_WARNINGS)
+ # set up output paths for executable binaries (.exe-files, and .dll-files on DLL-capable platforms)
+ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin)
endif()
add_definitions(-DSINGLETHREADED)