aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tony Wasserka <neobrainx@gmail.com>2014-12-07 22:22:04 +0100
committerGravatar Tony Wasserka <neobrainx@gmail.com>2014-12-07 23:52:17 +0100
commit4d4572c697616c43ce47f43fc5de1a1b9ae27d5f (patch)
tree8562e5e0b520cb7faae514595871e76c250553b5 /CMakeLists.txt
parent2db294306f18b076b0458244a051fe5ad23c957c (diff)
Integrate Boost into build system and perform a trivial cleanup in vertex_shader.cpp.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 05a56040..61d5d524 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,6 +19,14 @@ if (PNG_FOUND)
add_definitions(-DHAVE_PNG)
endif ()
+find_package(Boost)
+if (Boost_FOUND)
+ include_directories(${Boost_INCLUDE_DIRS})
+else()
+ message(STATUS "Boost not found, falling back to externals")
+ include_directories(externals/boost)
+endif()
+
# Include bundled CMake modules
list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/externals/cmake-modules")