aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Yuri Kunde Schlesner <yuriks@yuriks.net>2014-12-13 20:02:22 -0200
committerGravatar Yuri Kunde Schlesner <yuriks@yuriks.net>2014-12-15 19:34:17 -0200
commit06f31e8b471d5b54fee80568db2583d41e81fdb0 (patch)
treef3cbe39ae7bbcf4be2d40e3394c1b60939baeaaa /CMakeLists.txt
parent1ee740898ab6951e21fad864a40260c7d3c1027f (diff)
Clean up CMake library specification
The X11 libraries don't need to be specified when doing dynamic linking
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 61d5d524..0e48645d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,6 +6,7 @@ project(citra)
if (NOT MSVC)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wno-attributes")
+ add_definitions(-pthread)
else()
# Silence deprecation warnings
add_definitions(/D_CRT_SECURE_NO_WARNINGS)
@@ -75,10 +76,6 @@ if (ENABLE_GLFW)
set(GLFW_LIBRARIES glfw3)
else()
- if (NOT APPLE)
- find_package(X11 REQUIRED)
- endif()
-
find_package(PkgConfig REQUIRED)
pkg_search_module(GLFW REQUIRED glfw3)
endif()