aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar archshift <admin@archshift.com>2014-09-02 23:32:15 -0700
committerGravatar archshift <admin@archshift.com>2014-09-02 23:32:15 -0700
commit051b162add564dcc6f86be781df8d951a96a8015 (patch)
treed2f7820e7395aca9622a6093a9cdbbf3114490bb /CMakeLists.txt
parentc0e48432cd262baa6ed84b33cd9dd0d8f585e345 (diff)
Removed the need for X11 on OS X
It only causes issues when someone (who doesn't need it) doesn't have it.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e1614cd4..83b0863f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -65,7 +65,10 @@ if (ENABLE_GLFW)
set(GLFW_LIBRARIES glfw3)
else()
- find_package(X11 REQUIRED)
+ if (NOT APPLE)
+ find_package(X11 REQUIRED)
+ endif()
+
find_package(PkgConfig REQUIRED)
pkg_search_module(GLFW REQUIRED glfw3)
endif()